Author Topic: Issues Building h5py for BRAILS 2.0.5  (Read 3838 times)

SethReis

  • Newbie
  • *
  • Posts: 7
    • View Profile
Issues Building h5py for BRAILS 2.0.5
« on: August 25, 2023, 06:43:30 PM »
Hello,

I am attempting to install BRAILS 2.0.5 to make use of the SoftstoryClassifier, however, I am running into issues when it tries to build the wheel for h5py.

I have uninstalled and reinstalled numerous versions of h5py, I have independently installed hdf5, I have uninstalled and reinstalled other packages that might be involved, and I have tried pretty much everything I can find on the internet about it including using completely different Python versions. If anyone has any experience with this, please point me in the right direction.


SethReis

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Issues Building h5py for BRAILS 2.0.5
« Reply #1 on: August 28, 2023, 09:50:54 PM »
To anyone else who is facing similar issues, I have found that BRAILS 2.0.0 works.

fmk

  • Administrator
  • Full Member
  • *****
  • Posts: 232
    • View Profile
Re: Issues Building h5py for BRAILS 2.0.5
« Reply #2 on: August 29, 2023, 06:40:58 AM »
Seth .. thanks .. I was having the same problems .. neither google or stackoverflow was of any  help .. I did not think of trying an earlier version.