Author Topic: Python 3.9  (Read 138 times)

UMD_RiskGroup

  • Newbie
  • *
  • Posts: 1
    • View Profile
Python 3.9
« on: October 11, 2022, 08:49:20 PM »
Hi,

I'm new to R2D and have installed it following the online guidance. I'm attempting to follow the Lake Charles example. I've downloaded and imported all the associated building and hazard files.

When I run locally, I get the following error:
      16:41:12 - Python version 3.8 or 3.9 is required, you have Python version 3.9 installed

I followed the download instructions and downloaded Python version 3.9.13. I've since restarted my computer, but at a loss for what to try next. Should I dl an older version of Python? I'm using a Mac with and Intel processor. Any other advice?

Thanks!

steveg

  • Newbie
  • *
  • Posts: 22
    • View Profile
Re: Python 3.9
« Reply #1 on: October 12, 2022, 06:09:51 PM »
Hi,

That is bug that will be fixed in a future version of R2D. In your version, only Python 3.8 is supported, even though it says 3.9 should work. Therefore, you will have to use Python 3.8.

Note, that we are making substantial changes to the new version of R2D (coming out in the next week or two). The examples have been updated and may not work if downloaded through the examples manager built into R2D. I have attached an older versions of the examples file (Examples.json) that should replace the one in the R2D/Contents/MacOS/Examples folder. This will ensure that R2D downloads the examples that work with your version of R2D, i.e., an older version of the examples. Let me know if you still run into issues.

Best,
Steve